Back to overview
Downtime

Some services are down

Mar 01, 2026 at 06:03pm UTC
Affected services
play.herax.cc

Resolved
Mar 02, 2026 at 06:57pm UTC

play.herax.cc will be marked as resolved during the time of the maintenance.

Created
Mar 01, 2026 at 06:03pm UTC

play.herax.cc went down as a result of VPS expiry. Migration will happen soon. play.herax.cc will remain under maintenance.